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Revit Structure 3 – ETABS® Data Exchange

Overview
This document describes how to exchange Building Information Modeling (BIM) data 
between Revit Structure 3 and ETABS, a three-dimensional physical object based 
analysis and design package developed specifically for building type structures, including 
commercial, residential, healthcare and educational facilities. This transfer of information 
is two-way: data can be sent from Revit Structure to ETABS, and then Revit Structure 
can be updated with changes made in ETABS. A link also exists for sending a new 
model created in ETABS to Revit Structure without any prior Revit Structure file. 

Creating a single physical model in Revit Structure that can be accessed and used directly 
by ETABS reduces the time and effort associated with analytical model creation, as well 
as minimizes the chances of misinterpretation or data input error. Structural changes 
made in the ETABS program are easily coordinated with Revit Structure to keep the 
project, and hence drawings, up to date. The flow of information is idealized in the 
schematic below. 
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Introduction
A project created in Revit Structure can be opened in or exported to ETABS, where it 
can be modified, analyzed and designed. Changes to the frame section assignments, as 
well as composite beam data and end shear reactions may be imported back into Revit 
Structure to update the project. The entire model, or only a selected portion, can be sent 
to ETABS. The following components and entities can all be imported into ETABS: 

• Level

• Grid

• Material

• Frame

• Frame Section

• Wall

• Floor

• Footing

• Load Case

• Point Load

• Line Load

• Area Load

• Load Combination

A model created in ETABS can also be sent to Revit Structure to initialize a new 
project. In this case, the following components can be imported into Revit Structure:

• Level

• Grid

• Frame

• Floor

• Wall
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BIM Data Transferred to ETABS
When exporting a Revit Structure building model, some or all of the following data 
entities may be utilized by ETABS:

Level: Attributes include the level name and elevation, which are imported as story data 
into ETABS. ETABS allows the user to edit/modify the story data at the time of import 
as shown in the form below.

Grid: Attributes transferred include grid names, used as grid labels in ETABS, and grid 
points for locating the grid.

Material: This includes information such as the material type (i.e., steel, concrete, etc.), 
properties (e.g., Young’s Modulus), and material strengths. Any material associated with 
either a floor or frame in the Revit model will be exported to ETABS.

Frame: Attributes include geometry, assigned sections, frame families, which are 
converted to Auto Select Section lists in ETABS, frame releases and rigid links (end 
offsets), orientation angles, as well as design information such as camber and number of 
shear studs.
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Frame Section: Attributes transferred depend upon the type of section. For steel 
sections, the section name will be exported and then used by ETABS to look up a 
section in its own database (i.e., AISC, CISC, etc.). For other section types, various 
dimensional parameters will be exported. For example,  a rectangular concrete column 
will export the width (B) and height (H) of the section. 

Wall: Information exported includes geometry and thickness.

Floor: This information  includes floor geometry, number of layers, layer thickness, layer 
material, and floor span direction. If curves are used to define floor geometry in Revit 
Structure, ETABS will mesh the curved segments into a number of straight segments to 
approximate the curve. If more than one layer is defined within a floor, ETABS will treat 
the floor as a deck with concrete fill – a single layer is interpreted as a slab, which may 
have any assigned material.

Footing: Footing geometry is transferred, either as points for general footings or as 
width, length and thickness for rectangular footings. ETABS will set the base restraint to 
fixed for any column located within the boundaries of a footing.

Load Case: Attributes transferred include the load case name and category. Load case 
categories are mapped onto ETABS load case types, such as Dead → Dead, Live →
Live, Wind → Wind, Seismic → Quake, etc.

Point Load: This information includes the load case name, the location of the point 
load, and the associated force and moment in the three global directions (i.e., Fx, Fy, Fz, 
Mx, My, Mz).

Line Load: This information includes the load case name, the start and end point 
locations of the line load, and the associated force and moment in the three global 
directions. Vertical line loads which lie across more than one beam will be appropriately 
distributed to the beams by ETABS, however, lateral line loads should be limited to a 
single beam.

Area Load: Attributes exported are the load case name, the points used to define the 
geometry of the area load, and the load in the X, Y and Z global directions. Any non-
uniform surface load applied in Revit Structure will be automatically converted to a 
equivalent uniform area load by ETABS.

Load Combinations: This information includes the load combination name, the load 
cases, and the load case factors for each load combination. 
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BIM Data Transferred from ETABS to Revit Structure
After completing the analysis and design in ETABS of a model initially created in Revit 
Structure, the following data may be sent back to Revit Structure for updating the 
project.

Frame: Attributes transferred include the frame section, composite beam results(e.g., 
camber and design studs), and the maximum shear reaction at both ends. A warning 
message will be given by Revit Structure if ETABS has assigned a new section that does 
not currently reside in a structural family – structural families should be revised prior to 
updating the project. The Revit Structure project will also be updated with any frame 
location changes made in ETABS, as well as deletions and additions of frames made in 
ETABS.

If transferring a new model from ETABS to Revit Structure when no prior project
exists, the transfer will include Levels, Grids, Frames, Floors and Walls.

Procedure: Sending the Model to ETABS
The following steps describe how to share your model with ETABS.

NOTE: The import/export functions described in the following section require that a 
compatible version of ETABS be available and that the CSi data interchange application, 
CSiXRevitTM, be installed.

1. Select the Tool > External Tools > Send Model to ETABS… command. 
The Send Model to CSi Software dialog box is displayed. If you have selected 
some elements in the model, the Selected Objects Only check box is displayed 
allowing you to export only a subset of the model for analysis. If you have not 
selected a subset, this option is not available.

2. Click the Start button. The current file name is listed, and the objects in the 
model are counted. The Send Model to Csi Software dialog box will look as 
follows:
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3. Click the OK button to open the File Options (Send Model to ETABS) dialog 
box as shown below.
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4. In the Select CSi Software area, select the program you wish to use for analysis 
and design. Note that programs not available will be grayed out.

5. In the Select Options to Import area, you may select the objects that you wish 
to send through to ETABS. The default is all objects selected.

6. In the Select Import Mode area, select Start ETABS if you have ETABS 
installed on your computer and you wish to start ETABS directly from Revit 
Structure. This option will result in ETABS opening immediately and creating 
plan and 3-D views of the Revit project model.
Note: Revit Structure may appear to be unresponsive while running ETABS, 
and will remain in this suspended state until you exit ETABS. Therefore, to 
ensure that you do not lose recent changes to your project, make sure you save 
the model in Revit Structure just prior to starting ETABS.

7. In the Select Import Mode area, select Write ETABS REVIT Interchange 
File (EXR) if you do not wish to run ETABS directly. This would be the case if 
you are an architect and wish to write a file that can be shared with structural 
engineers running ETABS. This file can be imported into ETABS, analyzed and 
designed, and then sent back for updating the Revit Structure project. 

8. Click the OK button to either start ETABS or to write out the .EXR file.
9. If you have written out an .EXR file, this file may be imported into ETABS by 

starting the ETABS program, and going to the File > Import > Revit .exr
file… command.

Within ETABS, you can view, edit, analyze, and design the model as needed. ETABS 
allows for both static and dynamic analyses, as well as steel and concrete design. 
Changes made to any part of the model in ETABS are reflected in the analytical and 
physical model when it is imported back to Revit Structure. For example, if you change a 
column size from W14 x 68 to W14 x 99 based upon the design optimization in ETABS, 
the physical model is updated in Revit Structure. Note: Make sure that any new sections 
assigned in ETABS are available in the structural frame families used in Revit Structure 
prior to importing the updated file.

Procedure: Updating the Model from ETABS
The following steps describe how to update your Revit Structure project with 
information from your ETABS analysis and design.

NOTE: Before you can successfully update your project with ETABS model 
information, make sure that sections used in ETABS have been loaded into your Revit 
structural member families.

1. Once you have edited, analyzed and designed your structure in ETABS, save 
the ETABS file by selecting the File > Save… command. 

2A. If you started ETABS outside of Revit Structure, select the File > Export > 
Revit .exr File… command within ETABS to display the Export File For Revit 
dialog box shown below. Select the Update Existing Model in Revit option in
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the Option to Export area. Start Revit Structure, and click on the Tools > 
External Tools > Update model from ETABS… command and select an 
import file to display the File Options (Update Model from ETABS) dialog box, 
or;

2B. If you started ETABS from Revit Structure directly, exit ETABS by clicking on 
the File > Exit… command to return control to Revit Structure. Once ETABS 
is closed, the Revit Structure dialog box will change from File Options (Send 
Model to ETABS) to File Options (Update Model from ETABS) as shown 
below. 

3. On the File Options (Update Model from ETABS) dialog box, select the 
program you wish to import the data from in the Select CSi Software area. 
Note that programs not available will be grayed out.
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4. In the Select Options to Export area, you may select the objects that you wish 
to import from ETABS. The default is all objects selected.

5. Click the OK button to display the Update Model from CSi Software dialog 
box as shown below. If you have selected some elements in the model, the 
Selected Objects Only check box is displayed allowing you to import only a 
subset of the model for updating. If you have not selected a subset, this option 
is not available.

6. Click the Start button. A list of the objects updated in the model is displayed. 
7. Click the OK button to close the Update Model from CSi Software dialog box 

and complete the updating process.

Procedure: Importing a New Model from ETABS
The following steps describe how to create a Revit Structure project from a model 
initially created in ETABS.

NOTE: Before you can successfully update your project with ETABS model 
information, make sure that sections used in ETABS have been loaded into your Revit 
structural member families.

1. Once you have edited, analyzed and designed your structure in ETABS, save 
the ETABS file by selecting the File > Save… command. 

2. Select the File > Export > Revit .exr File… command. The Export File for 
Revit dialog box is displayed as shown below. 
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3. In the Option to Export area, select the Export as a new Revit Model option.
4. Click the OK button to close the Export File For Revit dialog box and open the 

Export ETABS Interchange Revit File dialog box. Enter a file name under 
which the .EXR file will be saved. 

5. Click the Save button to close the Export ETABS Interchange Revit File dialog 
box.

6. Start Revit Structure, and click on the Tools > External Tools > Import 
Model from ETABS as a new Revit Model… command to display the Open 
EXR File dialog box shown below.

7. Select a file from the Open EXR File dialog box, and click the Open button. 
This opens the Export ETABS model as New Revit Model dialog box shown 
below. Upon completion of the review, a new project will have been created in 
Revit Structure that contains the Levels, Grids, Frames, Floors and Walls as 



11

imported from ETABS.

Reviewing the Log File (.log) 
Every time a model is sent from Revit Structure to ETABS, or from ETABS to Revit 
Structure, a file with the extension .log is created. This file will list any errors or 
omissions encountered when generating the EXR file, and therefore, should be checked 
each time an exchange of data is performed. The .log file also lists the build numbers for 
CSIxRevit and Revit Structure, which should be identical to ensure that no mis-
interpretation of data occurs. The first few lines of the .log file will have the following 
format:

CSixRevit Revit API Version = 3.0
CSixRevit Revit API Build = 20060325_2300

Current Revit Version = Release 3
Current Revit Build = 20060325_2300

It is the “Build =” numbers that should be the same – having the same Version numbers 
but different Build numbers does not guarantee data consistency.


